Beiträge von Mdann

    Ja, genau das habe ich verglichen. :)


    Die Sättigung sinkt in dieser Richtung: BT.709 -> DCI-P3 -> BT.2020. Das ist auch völlig korrekt. Das Anzeigegerät muss das dann entsprechend interpretieren. Zumindest mein JVC macht das auch, wenn man das richtige Farbprofil wählt. Ich konnte nie einen großen Unterschied zwischen DCI-P3 (ich glaube, es heißt "Natürlich" am JVC) und BT.2020 ("BT.2020") am Projektor sehen. Die Unterschiede sind marginal.

    Ich bin auch der Meinung, dass es normal ist.

    Der Unterschied am JVC zwischen DCI-P3 und BT.2020 ist sehr klein, aber der Unterschied in mpv zwischen target-prim=bt.2020 und target-prim=dci-p3 ist deutlich sichtbar.

    Das ist genau das, was ich hier erwähnt hatte (mit Screenshots). MPV konvertiert so, dass der Sättigungsverlauf nicht zur nativen Primärfarbe hin abknickt. Eigentlich ist das auch nicht unbedingt falsch, weil Hue komplett erhalten bleibt. Im Testbild ist der Unterschied extrem auffällig, im Filmbild dagegen deutlich weniger.


    Euer Problem kann ich aber nicht nachvollziehen. Ich habe extra noch mal die Ausgabe der drei Farbräume (BT.709, DCI-P3 und BT.2020) verglichen. Die Sättigungen von MPV und madVR sind jeweils identisch und verhalten sich wie erwartet. Das kann kein grundsätzliches Problem sein.

    zwischen mpv und madvr ist es in etwa indentisch. "in etwa" weil mir mir momentat das Tone mapping unterschiedlich eingestellt ist.
    Wahrscheinlich ist es identisch.

    Es ging eher darum, dass sich das Bild ändert mit dem Farbraum


    zum Testen:

    Code: input.conf
    b apply-profile "b"
    m apply-profile "m"
    n apply-profile "n"

    zusatz am Ende der mpv.conf:

    dann einfach mit b,n und m durchschalten. Man sieht sofort, dass "n" mit bt.2020 am wenigesten Farbe beinhaltet

    Damit meinte ich das ich die LS nicht an die untere Wand hängen kann nur im oberen Segment also in der High Zone von Auro.

    Die drei Ebenen ergeben sich nicht durch die Höhe der Lautsprecher sondern des Winkels nach oben vom Sitzplatz ausgehend.
    Der Sinn des One-For-All Setups ist es, alle Formate abzudecken.
    Das geht aber erstmal nur bis max 7.1.4 (also ohne TS und CH). TS und CH würden in dem Fall bei Atmos stumm bleiben.

    Tatsächlich ist das 7.1.4 für Atmos mit Heights nicht wirklich schlechter als z.B. mit Einbaulautsprechern. Das wird inzischen sogar auch von Dolby vorgeschlagen.
    Umgekehrt ist aber Auro 3D mit Einbaulautsprechern nicht möglich, oder wenn man sie als Heights einstellt, nicht wirklich optimal.


    Letztendlich hängt viel von deinen Sehgewohnheiten ab. Atmos ist gerade, wenn man deutschen Ton schaut weniger relevant, als bei Englishem Ton.


    Ich persönlich würde mit einem ein One-For-All Setup mit 7.1.4 starten.

    Damit kannst du gemütlich testen und deine eigenen Geschmack finden

    Dann kannst du später immer noch erweitern auf 7.1.6 in der Atmos oder Auro 3D Variante (oder beides mit entsprechdem AVR).


    So habe ich das übrigens auch gemacht. Nur habe ich mit 5.1.4 gestartet und habe inzwíschen beide Layouts (also 7.1.6 Atmos + Auro 3D) and einem Denon 8500


    Hast du schon eine AVR? Wenn ja welchen?

    Interessant, dass es bei Dir auch so ist. Noch andere Leidensgenossen?


    Am reduzierten nativen Farbraum des Beamers kann es nicht liegen, denn bei Zuspielung per MadVR, einem Standalone UHD-Player oder auch einem Kodi-Player auf Basis von Coreelec (AMLogic-Chipsatz) funktioniert es ja korrekt und mein Sony-Beamer braucht auch kein BT.2020 Flag per HDMI, um BT.2020 darzustellen, da ich BT.2020 als Farbraum fest einstellen kann. Nur dennoch klappt es alleinig mit MPV nicht. Entwder ist da etwas in MPV nicht korrekt oder wir verstehen hier etwas bezüglich MPV und dessen Konfiguration falsch.

    Ich konnte den Effekt auch bei madvr sehen. Wenn ich z.B. unter Calibration -> "this display is already calibrated" wähle, dann wird das Bild mit dort mit gewähltem BT.2020 auch blasser im Verlgiech zu DCI-P3 (oder BT.709).
    Allerdings habe ich noch nicht direkt verglichen zwischen madvr BT.2020 und mpv BT.2020. Vlt ist es mit mpv noch blasser. Ich teste das später

    Ich habe in der config target-prim=dci-p3 und beamer auf BT.2020 eingestellt. Damit ist es weniger blass.

    Mit target-prim=bt.2020 finde ich es auch nicht gut. Das liegt denke ich mal daran,. dass der Beamer Bt.2020 garnicht darstellen kann sonder näher an DCI-P3 ist.

    Mir gefällt es so zumindest (mit dci-p3)

    Ich habe übrigens bei gpu-api=vulkan (Windows) das Problem, dass es manchmal ruckelt wenn mpv nicht im fullscreen ist. Mit gpu-api=opengl gibt es das Problem nicht und ich kann keine Nachteile feststellen.

    Das muss ich inzwischen wieder zurücknehmen. Mit opengl ist die Performance deutlich schlechter. Es bleibt also erstmal bei vulkan

    zur Klarstellung von HDR und SDR profilen:

    Code
    [HDR]
    profile-desc=HDR
    profile-cond=p["video-params/gamma"]=="pq"
    #deine HDR parameter
    [SDR]
    profile-desc=SDR
    profile-cond=(p["video-params/gamma"]~=nil and p["video-params/gamma"]~="pq")
    #deine SDR parameter

    Die extra Abfrage bei SDR auf ~= nil ist nötig, da sonst beide Profile geladen werden bei HDR. Bei vielen ist das aber wohl recht egal.


    Ich habe übrigens bei gpu-api=vulkan (Windows) das Problem, dass es manchmal ruckelt wenn mpv nicht im fullscreen ist. Mit gpu-api=opengl gibt es das Problem nicht und ich kann keine Nachteile feststellen.

    Ich bin zu blöd die Option "sub-forced-only=yes" richtig zu benutzen.

    Entweder sehe ich immer Subs oder Nie. Aber nur "forced" funktioniert bei mir einfach nicht.


    Deshalb schnell ein Script gebastelt. Es wählt nur forced subtitles in der gewählten Sprache aus.

    Vlt ja hilfreich für wen auch immer


    Edit: geht jetzt auch mit "forced" in Namen + bugfix

    generell gibt es Unterschiede bei allen Tonemapping mit den beiden Optionen an oder aus (hier für hable):


    mit gpu-next + vulkan (target-peak=50):

    ohne gpu_next + vulkan (target-peak=50):



    mit gpu-next + vulkan (target-peak=100):

    ohne gpu_next + vulkan (target-peak=100):

    Alle anderen Einstellugen sind identisch!


    Man beachte vorallem die Artefakte bei target-peak=100 in den Wolken. Die treten mit gpu-next + vulkan nicht auf.

    Außerdem gibt es starke Helligkeitsunterschiede mit und ohne gpu-next + vulkan


    Auch mit bt.2390 gibt es deutliche Unterschiede.