Verbindungsproblem Nvidia 4070ti --> Stormaudio: kein Atmos

  • Hallo,


    da Ich hier im Forum keinen klassischen Thread zur StormAudio gefunden habe, hatte ich mein Anliegen bereits mal im HiFi Forum beschrieben.


    Ich nutze einen HTPC mit Windows 10, bei dem ich mit der Yamaha CX –A5100 problemlos Dolby Atmos ausgeben konnte.

    Nun habe ich auf eines StormAudio gewechselt, nun wird mir unter Windows im Menü „Raumklang“ lediglich Stereo, 5.1 und 7.1 angezeigt. Diese Geschichte mit der Dolby App ist nur für Kopfhörer erforderlich. Ich habe die Testversion ausprobiert, das ändert aber auch nichts.

    Ausgegeben wird tatsächlich maximal 7.1 als PCM. Gleiches liegt bei der Zuspiel von einem MacBook über USB-C zu HDMI vor.

    Daher gehe ich schon von einem Problem mit der StormAudio aus.

    Der Support von StormAudio konnte mir bisher auch nicht weiterhelfen.


    zozi hatte mir den Hinweis gegeben, dass es zumindest früher einige Probleme mit den Audiotreibern und Nvidia gab. Da liest man einige ältere Sachen, wie z.B. diese hier. Der Austausch der Audiodatei im Treiber funktioniert allerdings nicht mehr, da die Treiber der 500er-Reihe nach dem entpacken bei geöffneten Installationsprogramm schreibgeschützt sind, und nach dem Schließen der Software werden die Dateien gelöscht.

    Den genannten alten Treiber kann ich auch nicht installieren. Der scheint mit meiner Grafikkarte nicht kompatibel zu sein.

    Wenn ich aus dem Gerätemanager das "NVIDIA High Definition Audio device" entferne und stattdessen von Windows das „High Definition Audio Gerät“ installiere, ändert sich nichts an der Kanal Auswahl in den Windows Einstellungen der Audioausgabe durch die Storm.


    Kann mir irgendjemand weiterhelfen?

    Wäre total toll.


    Liebe Grüße,

    Nico


    EDIT erklärt uns die Lösung:

    In meiner Konfiguration musste HDMI 2 verwendet werden, weil es sonst Probleme mit EDID gibt. Da komm' mal einer drauf... Alles andere hatte ich versucht :rofl::rofl::rofl:

    ...nein, ich fahre (leider) keinen Porsche. (auf die häufige Frage zu meinem Nicknamen).

    Edited once, last by nl-911 ().

  • Hallo Nico,

    Ein Mac kann kein HD Signal als Bitstreaming ausgegeben. Das herauszufinden hat echt Nerven gekostet.


    Eventuell mit einem anderen Htpc oder mit anderer Grafikkarte testen? Was mir auf die Schnelle einfällt:

    - anderes Hdmi Kabel

    - beide NVidia Treiber (Gaming bzw. Studio) probiert?

  • Gerade auch im Hififorum geschrieben:


    Na ja, wenn es vorher ging, wirds wohl an der Vorstufe liegen, die Mehrheit verwendet Nvidia Grakas im HTPC.


    Ich kann auf die Schnelle nur sagen, dass es normal ist, unter Win max. 7.1 zu bekommen.


    Filmton wird vom Player jedoch durch geschliffen, so dass Win damit eigentlich nichts zu tun haben sollte.


    Gabs auch Änderungen beim Player, bei den LAV Filtern?


    Schon mit verschiedenen Playern, direkt aus dem Expolorer, ohne Kodi, etc. gestartet probiert?

    MPC-BE und mit MPC-HC, VLC?

  • Ausgegeben wird tatsächlich maximal 7.1 als PCM

    D.h., es wird grundsätzlich kein Bitstream ausgegeben?

    Da stimmt irgendeine Einstellung nicht, ich würde da doch eher auf den HTPC als die Vorstufe tippen.


    Was bei meiner Installation übrigens wichtig ist:

    Zuerst die Altitude einschalten, erst wenn diese hochgefahren ist den HTPC.

    Wenn ich den HTPC zu früh einschalte kommt es zu merkwürdigen Phänomenen, z.B. wird RGB in limited statt full ausgegeben obwohl die EInstellungen auf full stehen.

  • Tach,


    nl-911

    Hilft Dir vielleicht insofern, dass es prizipiell funktioniert. Ich hatte keine Probleme mit dem Bitstreaming an der Storm und einer 4090. Das habe ich nur nebenbei gemerkt, weil ich etwas zwischen Envy + PC vergleichen/testen wollte. Welches Board ist in der Storm + welche FW? Das OS bei mir ist W11Pro mit den (nicht mal aktuellen) Studiotreibern.

  • Die Dolby Access App ist nicht nur für Kopfhörer, sondern einfach nur (bewusst ?) schlecht gemacht. Habe zwar WIN 11 auf meinem HTPC aber auch eine Stormaudio Vorstufe.

    Wenn du in der Dolby Access App rechts unten auf "Überspringen" klickst, dann kommst du zu den "Produkten", das rechte Symbol steht für die dort "Dolby Atmos for Home Theater" Einstellungen. Dort solltest du schauen, dass der Haken bei "Einsatzbereit" vorhanden ist.


         


    Wenn der Haken vorhanden ist, kannst du in den Windows Sound Einstellungen (Screenshot für Win 11, Win 10 wird aber ähnlich sein) dann noch überprüfen, ob für die Storm unter "Raumklang" dann auch Atmos eingetragen ist.



    Wenn nicht, dann kann noch sein, dass du in den Soundeinstellungen noch auf "Konfigurieren" klicken musst und dort Atmos für die Storm auswählen musst.



    Bei mir funktioniert das mit einer 4070 und der Sotrm MK2 tadellos.

    Gruß, Jürgen

  • ... Der Austausch der Audiodatei im Treiber funktioniert allerdings nicht mehr, da die Treiber der 500er-Reihe nach dem entpacken bei geöffneten Installationsprogramm schreibgeschützt sind, und nach dem Schließen der Software werden die Dateien gelöscht. ...


    Du könntest während das Installationsprogramm geöffnet ist, die entpackten Dateien in ein anderes Verzeichnis kopieren. Dort werden sie dann nicht gelöscht.

  • Und wofür wir diese Dolby Access App am HTPC benötigt?

    Möchtest du nicht die unveränderte Tonspur als Bitstream ausgeben?

    Ohne die Dolby App habe ich bisher kein Atmos aus Win11 wiedergeben können. Aber bin an einer alternativen Lösung interessiert wenn es eine gibt.

  • Moin,


    vielen Dank für die Reaktionen. Nur ihr könnt euch vorstellen, wie sehr ich leide :sad:


    Zu den Tipps:

    Surfreak habe drei HDMI-Kabel ohne Unterschied probiert.

    Studiotreiber im Vergleich zu den vorherigen Gamingtreibern ändern leider auch nichts.

    Einen anderen PC habe ich leider nicht zur Verfügung.


    Mankra tatsächlich habe ich im Rahmen eines K-lite-Codec-Updates auch ein LAV-Update installiert --> wie kann ich an dem Punkt die Fehlersuche anknüpfen?

    alle Playerprogramme, die ich habe (MPC, MPC-HC, VLC, WMP, bringen das gleiche Ergebnis


    Aries tatsächlich wird PCM ausgegeben, kein Bitstream. Wo kann ich das denn variieren? Wie ist es bei anderen Stormbesitzern?


    Peter911 Software der Storm ist die 4.5r2p3, also die Neueste verfügbare, da die 4.6. zurückgezogen wurde. HDMI-Board ist 7+2 eARC


    jgs Den Dolby Access-Vorgang habe ich auch soweit durchgemacht.

    Klicke ich auf


    Kommt Folgendes:


    ... und in den Eigenschaften kann ich dann bei der Storm wieder nur bis 7.1. (und bei der Yamaha auch Atmos und das sogar ohne Konfiguration der Dolby Access-App) auswählen.




    Namor Noditz Ich schreibe mal meine Einstellung aus MPC-HC. Alles ist auf Standard. Was sollte ich da verstellen?




    Wenn ich in letzen Bild den Haken oben setze, kann ich die Storm auswählen und die drei zuvor ausgegrauten Optionen aus der Mitte sind editierter.




    Auch das Spiel "Hogwarts", was sicher einen Atmos-Sound hat, wird nur als PCM 7.1 ausgegeben.


    Tja, leider weiß ich erst einmal nicht weiter...



    Edit:

    timm Ja, das geht. Wenn ich allerdings den HD-Audio-Treiber aus der wohl noch funktionierenden Version 388.59 (die sich leider mit meiner Grafikkarte nicht installieren lässt) in neuere Treiber, z.B. 551.86 oder 552.44 kopiere, erscheint der Audiotreiber nicht mehr als Option im Setup. Ich könnte mir vorstellen, dass der Installer eine instrinsiche Prüfung vornimmt und das "gemuxe" erkennt. Direkt über den Gerätemanager konnte ich den alten Audiotreiber auch nicht installieren (die besten Treiber sind bereits installiert, schreibt mir Windows).

    ...nein, ich fahre (leider) keinen Porsche. (auf die häufige Frage zu meinem Nicknamen).

    Edited 2 times, last by nl-911 ().

  • Hattest du vorher schon k-lite installiert? Je nach Paket bringt der seinen eigenen MPC-HC mit, prüfe das mal in der k-lite Installation.

    Evtl. spielt da ein anderer (zweiter) MPC......

    schreibe mal meine Einstellung aus MPC-HC. Alles ist auf Standard. Was sollte ich da verstellen?

    Du hast LAV Filter installiert ? Dann musst du im MPC auch entsprechend die Filter/Codecs abwählen die vom externen LAV übernommen werden sollen.


    Ich würde mal alles rausschmeißen, LAV, k-lite, alle Mediaplayer und möglichst weit von vorne beginnen.

  • Du musst Spiele und Filme getrennt betrachten.

    Bei Filmen wollen wir den unveränderten Bit-Stream 1:1 von der "Disc" zum AVR senden. Da muss die Soundkarte gar nichts tun!

    Bei Spielen werden, so weit mir bekannnt, die Funktionen der HDMI-Soundkarte (Treiber) genutzt, um den Mehrkanalton zu berechnen (rendern).

    Also für Spiele ist die Atmos-Funktion der Soundkarte relevant, für Filme nicht.


    Folgendes sind meine Einstellungen im MPC-HC:







    Wichtig noch zum LAV. Die tatsächlich gerade aktive LAV Decoder Version wird als Hintergrund-Anwendung als Symbol bei der Uhrzeit angezeigt.


  • Tach,


    Software der Storm ist die 4.5r2p3, also die Neueste verfügbare, da die 4.6. zurückgezogen wurde.

    Also, bei mir läuft die 4.6 seit dem Update von 4.5r2p3 völlig fehlerfrei; ich hatte sogar noch mit der vorherigen einen wirklich schlimmen Bug beim mehrfachen Umschalten der „Theatres“. Jetzt nicht mehr.


    Bin kein HTPC Fummler, aber bei meinem Test habe ich nix von diesem ganzen ATMOS-Treiber-App Gerumpel installiert. Bin einfach mit Bitstream in die Storm. Wenn Du PCM ausgibst, dann decodiert ja dein PC… Aber hier wissen die reinen HTPC Experten sicher mehr. Mir war gar nicht klar, dass das überhaupt problematisch sein kann🙈

  • Hallo,


    vielen Dank für die Tipps.

    Habe die Einstellungen mal alle so übernommen (und vorher sehr ähnlich gehabt). Es ändert nichts.


    Immerhin konnte ich im Rahmen eines Support- und-Seelentröster-WhatsApp-Chat mit einer super Osnabrücker Truppe herausdröseln, dass es mit manchen Formaten, z.B. Auro, DTS, EAC3 aber nicht mit TrueHD Atmos geht.


    Also ist die Storm und die NVIDIA 4700 ti schon mal brav, dafür diese LAV-Filter um so böser :dry:


    Ich benutze die LAV 0.79.2. Ich versuche mal mit anderen Versionen zu experimentieren.

    Wie blöd von mir ach so leichtsinnig im Rahmen des Vorverstärkerwechsels mal so nebenbei das angebotene Update vom K-Lite-Codec-Pack zu akzeptieren.


    Peter911 Oh ja, ich hatte auch nie geglaubt, dass ein Update solche Probleme bereiten kann!

    wie hast du das denn eingestellt, dass du ausschließlich mit Bitstream in die Storm gehst?


    Edit: Inzwischen habe ich herausgefunden, dass die LAV-Filter in MPC-HC bei TrueHD Atmos nur PCM ausgibt


    Da muss man ja erst einmal drauf kommen. Doof nur, dass all meine Dateien in TrueHD vorliegen...
    Ich habe viele LAV-Versionen bis 0.74 runter ausprobiert, aber alle verhalten sich gleich.

    Wenn mann googlet scheint das kein unübliches Problem zu sein, da es ständig gefixed wird -bei mir aber trotzdem nicht nicht läuft.


    Ich habe MPC-HC-64 und K-Lite komplett entfernt und nur MPC-HC64, MadVR und verschiedene LAV-Versionen einzeln installiert. Es geht leider trotzdem nicht.


    Was könnte ich noch tun?


    An dieser Stelle muss ich einmal klarstellen, dass die Storm Audio da definitiv nichts falsch macht. Sie empfängt das Signal einfach nur so, wie es vom HTPC ausgegeben wird!

    ...nein, ich fahre (leider) keinen Porsche. (auf die häufige Frage zu meinem Nicknamen).

    Edited once, last by nl-911 ().

Jetzt mitmachen!

Don’t have an account yet? Register yourself now and be a part of our community!