Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: Wie gewöhne ich madvr das scalen ab?

Wie gewöhne ich madvr das scalen ab? 12 Aug 2019 14:49 #1

  • thorsten
  • thorstens Avatar
  • Offline
  • User
  • Beiträge: 111
  • Dank erhalten: 33
HAllo zusammen,

nachdem ich nun endlich mal ausprobieren wollte, ob meine Graka 4k schafft, komme ich nicht weiter und brauche eure Hilfe.

Setup:
Win10, Jriver MC25+madvr -> Radeon HD7700 -> JVC X500 (HDMI2)
Das Display habe ich unter Win10 auf 3840*2160 gestellt. Wird vom JVC als 4k2kp30 erkannt

Wenn ich jetzt eine UHD abspiele, ruckelt es wie Hölle. Warum? U.a. weil madvr ein scaling auf 0,0,1920,1080 macht und ich nicht weiß, wie ich das unterdrücken kann.
Anbei ein Screenshot der einstellungen.



Danke schonmal für eure Hilfe,

Thorsten
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Wie gewöhne ich madvr das scalen ab? 12 Aug 2019 14:52 #2

  • thorsten
  • thorstens Avatar
  • Offline
  • User
  • Beiträge: 111
  • Dank erhalten: 33
Ach ja: Zoom control ist komplett aus und der Beamerspielt in 4k2k ab :mad:
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Wie gewöhne ich madvr das scalen ab? 12 Aug 2019 15:13 #3

  • Moe
  • Moes Avatar
  • Online
  • User
  • Beiträge: 249
  • Dank erhalten: 32
Ist das Display so konfiguriert im Graka-Treiber, dass 4k überhaupt erkannt wird? Hatte ich letztens wieder das mein HTPC "dachte" der Beamer / Denon könne nur Full-HD.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Wie gewöhne ich madvr das scalen ab? 12 Aug 2019 15:41 #4

  • sven29da
  • sven29das Avatar
  • Offline
  • Vereinsmitglied
  • Beiträge: 1023
  • Dank erhalten: 208
Hallo Thorsten,
bin jetzt kein Spezi aber könnte es sein, dass Du die möglichen Auflösungen an der Stelle nicht eingetragen hast?
Ich möchte bei mir nur 2160 ausgeben, deshalb steht bei mir auch nur 2160 mit allen möglichen Varianten drin.

Dann könnte ich mir vorstellen, dass das was Du beschriebst passiert.




Viel Erfolg
Sven
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Wie gewöhne ich madvr das scalen ab? 12 Aug 2019 15:50 #5

  • DoXer
  • DoXers Avatar
  • Offline
  • Vereinsmitglied
  • Beiträge: 1670
  • Dank erhalten: 201
Thorsten,
schau Dir mal Bild 7 an www.partyfotos.de/madVR/settings/
Das liegt daran, das madVr so ausgibt und skaliert wie der Treiber eingestellt ist, bei Dir also momentan immer 3840x2160.
In dem Setting (Bild 7) siehst Du die Zeile mit 2160p23 usw.
Nun musst Du per Regel (also 1920 Kontent) einen Setting einrichten, welches bei 1920 Einträge mit 1080P23 usw enthält. Dann schaltet madVR die Auflösung der Grafikkarte auf 1920x1080 und so bekommt es dann auch der Beamer/FlatScreen.

Eine Referenz zu den Rules findest Du hier. forum.doom9.org/showthread.php?t=146228
--
Gruß
Michael
Letzte Änderung: 12 Aug 2019 16:23 von DoXer.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Wie gewöhne ich madvr das scalen ab? 12 Aug 2019 15:51 #6

  • DoXer
  • DoXers Avatar
  • Offline
  • Vereinsmitglied
  • Beiträge: 1670
  • Dank erhalten: 201
Sven,
zeige nochmal den Screen Deiner Rules (Sven Calibration Config) , das erklärt es dann besser.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Wie gewöhne ich madvr das scalen ab? 12 Aug 2019 16:11 #7

  • sven29da
  • sven29das Avatar
  • Offline
  • Vereinsmitglied
  • Beiträge: 1023
  • Dank erhalten: 208
Letzte Änderung: 12 Aug 2019 16:13 von sven29da.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Wie gewöhne ich madvr das scalen ab? 12 Aug 2019 16:21 #8

  • DoXer
  • DoXers Avatar
  • Offline
  • Vereinsmitglied
  • Beiträge: 1670
  • Dank erhalten: 201
Genau, wobei ich es dann nicht mit filepath lösen würde sondern...

if (srcWidth < 2000)
"HD"
else
"UHD"


Aber das macht jeder anders...
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Wie gewöhne ich madvr das scalen ab? 12 Aug 2019 16:27 #9

  • hocky
  • hockys Avatar
  • Offline
  • User
  • Beiträge: 403
  • Dank erhalten: 72
Naja, aber thorsten schreibt ja
thorsten schrieb:
Beamerspielt in 4k2k ab :mad:

Also sollte es doch daran eigentlich nicht liegen.

ich stolpere ein wenig über das "windowed" im madVR-Status. Probier doch mal unter "rendering => general setting => enable automatic fullscreen exclusive mode".
Letzte Änderung: 12 Aug 2019 16:27 von hocky.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Wie gewöhne ich madvr das scalen ab? 12 Aug 2019 16:47 #10

  • sven29da
  • sven29das Avatar
  • Offline
  • Vereinsmitglied
  • Beiträge: 1023
  • Dank erhalten: 208
DoXer schrieb:
Genau, wobei ich es dann nicht mit filepath lösen würde sondern...

if (srcWidth < 2000)
"HD"
else
"UHD"


Aber das macht jeder anders...

Mhhh, wusste nicht das man auch an der Stelle mit der Auflösung arbeiten kann.
Kenne es nur von Rubrik "Processing Settings" :think:

Habe jetzt überlegt ob ich das zur Sicherheit noch bei mir zusätzlich eintrage, was vermutlich mit "or" gehen müsste, dann viel mir aber ein das ich auch Demos in 2160 habe, die kein HDR besitzen. Mhhh, da ich eigentlich bislang keine Probleme, lasse ich es am besten :blush:

Bin mal gespannt wann ich mal ein anderesmadVR System live erlebe.
Vielleicht schaue ich die ganze Zeit mit angezogener "Handbremse" und das Bild könnte erheblich schöner sein ... wer weis :poppy:
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Wie gewöhne ich madvr das scalen ab? 12 Aug 2019 17:01 #11

  • audiohobbit
  • audiohobbits Avatar
  • Offline
  • User
  • Beiträge: 137
  • Dank erhalten: 7
Ich hab 0 Ahnung von madVR, aber mir stieß folgendes auf:
. Wird vom JVC als 4k2kp30 erkannt
24p Film auf 30p? -> Ruckeln. evtl. damit was zu tun?
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Wie gewöhne ich madvr das scalen ab? 12 Aug 2019 17:02 #12

  • DoXer
  • DoXers Avatar
  • Offline
  • Vereinsmitglied
  • Beiträge: 1670
  • Dank erhalten: 201
hocky schrieb:
Naja, aber thorsten schreibt ja
thorsten schrieb:
Beamerspielt in 4k2k ab :mad:

Also sollte es doch daran eigentlich nicht liegen.

ich stolpere ein wenig über das "windowed" im madVR-Status. Probier doch mal unter "rendering => general setting => enable automatic fullscreen exclusive mode".

Nein, bitte nicht. FSE sollte unter Win10 nicht mehr benutzt werden. Es liegt an den von Sven und mir beschriebenen Bereich..
--
Gruß
Michael
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Wie gewöhne ich madvr das scalen ab? 12 Aug 2019 17:18 #13

  • thorsten
  • thorstens Avatar
  • Offline
  • User
  • Beiträge: 111
  • Dank erhalten: 33
Hallo zusammen,

danke schonmal! (werde es später ausprobieren)
Ich hatte schon 2160p23 bei den display modes eingestellt, das war dem system aber herzlich egal. Auch 3860x2160p23 ging nicht.
In den properties vom JVC stehen auch nur nativ 1920x1080 drin (kann ich aber nicht ändern).

Und ja, ich hatte die Ausgabe beim Film schon tatsächlich 4k2kp24 am Beamer, aber das Bild wurd erst runter- und dann wieder hoch gerechnet.

Schönen Gruß
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Wie gewöhne ich madvr das scalen ab? 12 Aug 2019 17:26 #14

  • Moe
  • Moes Avatar
  • Online
  • User
  • Beiträge: 249
  • Dank erhalten: 32
Du kannst im Windows für deinen Beamer kein 4k konfigurieren als Auflösung?



Wie gesagt, das hat sich bei mir bisher 2x verstellt und dann kam auch nur Full-HD raus.
Letzte Änderung: 12 Aug 2019 17:29 von Moe.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Wie gewöhne ich madvr das scalen ab? 13 Aug 2019 00:02 #15

  • wobix
  • wobixs Avatar
  • Offline
  • User
  • Beiträge: 340
  • Dank erhalten: 53
Ist ein weiterer Monitor in FullHD angeschlossen?
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Wie gewöhne ich madvr das scalen ab? 13 Aug 2019 18:46 #16

  • Moe
  • Moes Avatar
  • Online
  • User
  • Beiträge: 249
  • Dank erhalten: 32
Mal noch ein weiteres Thema, was das Scaling angeht. Sobald ich MadVR gestatte 1080p auf 2160p upzuscalen sieht es deutlich schärfer aus, aber in schnellen Bewegungen habe ich immer deutliche Artefakte. Kaum gebe ich in 1080p aus, sind diese vollständig verschwunden. Bei 2160p Inhalten passiert nichts dergleichen. Konfiguriert habe ich die betreffenden Bereich wie bei Bernd dokumentiert, habe aber auch einiges anderes versucht, dennoch egal was ich einstelle, sobald ich upscaling nutze, gibt es Artefakte.
Nutze eine 1080ti und Renderingzeiten sind voll i.O. (<15ms).
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Ladezeit der Seite: 0.171 Sekunden
Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.
Weitere Informationen Ok